Logo Brandihan status page

Short maintenance

  • Resolved
    Maintenance is now finished. Brandihan will have another maintenance upgrade in the future to move to Ghost 6. Brandihan will stay in Ghost 5 for now.
  • Investigating
    We are having a short maintenance due to cleanup at server site.